ExtLine1Point Property (ActiveX)

Specifies the origin of extension line 1.

Supported platforms: Windows only

Signature

VBA:

object.ExtLine1Point
object

Type: DimAligned, DimArcLength

The objects this property applies to.

Property Value

Read-only: No

Type: Variant (three-element array of doubles)

A 3D coordinate representing the origin of the first extension line.

Remarks

The dimension line of an aligned dimension will be parallel to the line joining the origins of extension lines 1 and 2.



Line to be dimensioned



Dimension created

Examples

VBA:

Sub Example_ExtLine1Point()
    ' This example creates an aligned dimension and then changes the
    ' ExtLine1Point property for that dimension.

    Dim dimObj As AcadDimAligned
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    
    ' Define the dimension
    point1(0) = 5#: point1(1) = 5#: point1(2) = 0#
    point2(0) = 10#: point2(1) = 5#: point2(2) = 0#
    location(0) = 5#: location(1) = 7#: location(2) = 0#
    
    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    ZoomAll
    MsgBox "The current value for ExtLine1Point is " & dimObj.ExtLine1Point(0) & ", " & dimObj.ExtLine1Point(1) & ", " & dimObj.ExtLine1Point(2), vbInformation, "ExtLine1Point Example"
    
    ' Change the endpoint of the first extension line
    point1(0) = 2: point1(1) = 5: point1(2) = 0
    dimObj.ExtLine1Point = point1
    dimObj.Update
    
    ' Return the endpoint of the first extension line
    ' Note that the return value is a Variant
    Dim retPnt As Variant
    retPnt = dimObj.ExtLine1Point
    
    MsgBox "The new value for ExtLine1Point is " & dimObj.ExtLine1Point(0) & ", " & dimObj.ExtLine1Point(1) & ", " & dimObj.ExtLine1Point(2), vbInformation, "ExtLine1Point Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ExtLine1Point()
    ;; This example creates an aligned dimension and then changes the
    ;; ExtLine1Point property for that dimension.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the dimension
    (setq point1 (vlax-3d-point 5 5 0)
          point2 (vlax-3d-point 10 5 0)
          location (vlax-3d-point 5 7 0))
    
    ;; Create an aligned dimension object in model space
    (setq modelSpace (vla-get-ModelSpace doc))  
    (setq dimObj (vla-AddDimAligned modelSpace point1 point2 location))
    (vla-ZoomAll acadObj)

    (setq extLinePoint (vlax-safearray->list (vlax-variant-value (vla-get-ExtLine1Point dimObj))))
    (alert (strcat "The current value for ExtLine1Point is " (rtos (nth 0 extLinePoint) 2) ", "
		                                             (rtos (nth 1 extLinePoint) 2) ", "
		                                             (rtos (nth 2 extLinePoint) 2)))
  
    ;; Change the endpoint of the first extension line
    (setq point1 (vlax-3d-point 2 5 0))
    (vla-put-ExtLine1Point dimObj point1)
    (vla-Update dimObj)
    
    ;; Return the endpoint of the first extension line
    ;; Note that the return value is a Variant
    (setq retPnt (vlax-safearray->list (vlax-variant-value (vla-get-ExtLine1Point dimObj))))
    (alert (strcat "The new value for ExtLine1Point is " (rtos (nth 0 retPnt) 2) ", "
		                                         (rtos (nth 1 retPnt) 2) ", "
		                                         (rtos (nth 2 retPnt) 2)))
)