User Property (ActiveX)

Gets the PreferencesUser object.

Supported platforms: Windows only

Signature

VBA:

object.User
object

Type: Preferences

The object this property applies to.

Property Value

Read-only: Yes

Type: PreferencesUser

Gets the PreferencesUser object.

Remarks

The PreferencesUser object holds all the options from the User tab on the Options dialog stored in the registry. All options that are stored with the drawing can be found on the DatabasePreferences object.

Examples

VBA:

Sub Example_User()
    ' This example obtains a reference to the User Preferences object
    ' from the Application Preferences object, and reads one of the User
    ' preferences
    
    Dim ACADPref As AcadPreferencesUser
    
    ' Obtain a reference to the User Preferences object
    Set ACADPref = ThisDrawing.Application.preferences.User
    
    MsgBox "You now have access to the properties and methods of the User Preferences object!"
    MsgBox "The User preference KeyboardAccelerator is set to: " & ACADPref.KeyboardAccelerator

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_User()
    ;; This example obtains a reference to the User Preferences object
    ;; from the Application Preferences object, and reads one of the User
    ;; preferences
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    (alert "You now have access to the properties and methods of the User Preferences object!")
    (alert (strcat "The User preference KeyboardAccelerator is set to: " (if (= (vla-get-KeyboardAccelerator (vla-get-User preferences)) :vlax-true) "True" "False")))
)