CustomDictionary Property (ActiveX)

Specifies a custom dictionary to use if you have one.

Supported platforms: Windows only

Signature

VBA:

object.CustomDictionary
object

Type: PreferencesFiles

The object this property applies to.

Property Value

Read-only: No

Type: String

The custom dictionary to use.

Remarks

This property contains the drive, path, and file name of the custom dictionary for the AutoCAD session.

Examples

VBA:

Sub Example_CustomDictionary()
    ' This example returns the current setting of
    ' CustomDictionary. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim preferences As AcadPreferences
    Dim currCustomDictionary As String
    Dim newCustomDictionary As String
    
    Set preferences = ThisDrawing.Application.preferences
    
    ' Retrieve the current CustomDictionary value
    currCustomDictionary = preferences.Files.CustomDictionary
    MsgBox "The current value for CustomDictionary is " & currCustomDictionary, vbInformation, "CustomDictionary Example"
    
    ' Change the value for CustomDictionary
    newCustomDictionary = "TestCustomDictionary.cus"
    preferences.Files.CustomDictionary = newCustomDictionary
    MsgBox "The new value for CustomDictionary is " & newCustomDictionary, vbInformation, "CustomDictionary Example"
    
    ' Reset CustomDictionary to its original value
    preferences.Files.CustomDictionary = currCustomDictionary
    MsgBox "The CustomDictionary value is reset to " & currCustomDictionary, vbInformation, "CustomDictionary Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_CustomDictionary()
    ;; This example returns the current setting of
    ;; CustomDictionary. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Retrieve the current CustomDictionary value
    (setq currCustomDictionary (vla-get-CustomDictionary (vla-get-Files preferences)))
    (alert (strcat "The current value for CustomDictionary is " currCustomDictionary))
    
    ;; Change the value for CustomDictionary
    (setq newCustomDictionary "TestCustomDictionary.cus")
    (vla-put-CustomDictionary (vla-get-Files preferences) newCustomDictionary)
    (alert (strcat "The new value for CustomDictionary is " newCustomDictionary))
    
    ;; Reset CustomDictionary to its original value
    (vla-put-CustomDictionary (vla-get-Files preferences) currCustomDictionary)
    (alert (strcat "The CustomDictionary value is reset to " currCustomDictionary))
)