DisplayLayoutTabs Property (ActiveX)

Specifies whether to display the Model and layout tabs in the drawing editor.

Supported platforms: Windows only

Signature

VBA:

object.DisplayLayoutTabs
object

Type: PreferencesDisplay

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value for this property is True.

Examples

VBA:

Sub Example_DisplayLayoutTabs()
    ' This example reads and modifies the preference value that controls
    ' the display of the Model and layout tabs. When finished, this example
    ' resets the preference value back to its original value.
    
    Dim ACADPref As AcadPreferencesDisplay
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the display preferences object
    Set ACADPref = ThisDrawing.Application.Preferences.DISPLAY
    
    ' Read and display the original value
    originalValue = ACADPref.DisplayLayoutTabs
    MsgBox "The DisplayLayoutTabs preference is set to: " & originalValue

    ' Modify the DisplayLayoutTabs preference by toggling the value
    ACADPref.DisplayLayoutTabs = Not (originalValue)
    newValue = ACADPref.DisplayLayoutTabs
    MsgBox "The DisplayLayoutTabs preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.DisplayLayoutTabs = originalValue
    MsgBox "The DisplayLayoutTabs preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_DisplayLayoutTabs()
    ;; This example reads and modifies the preference value that controls
    ;; the display of the Model and layout tabs. When finished, this example
    ;; resets the preference value back to its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))

    ;; Get the display preferences object
    (setq ACADPref (vla-get-Display preferences))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-DisplayLayoutTabs ACADPref))
    (alert (strcat "The DisplayLayoutTabs preference is set to: " (if (= originalValue :vlax-true) "True" "False")))

    ;; Modify the DisplayLayoutTabs preference by toggling the value
    (vla-put-DisplayLayoutTabs ACADPref (if (= originalValue :vlax-true) :vlax-false :vlax-true))
    (setq newValue (vla-get-DisplayLayoutTabs ACADPref))
    (alert (strcat "The DisplayLayoutTabs preference has been set to: " (if (= newValue :vlax-true) "True" "False")))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-DisplayLayoutTabs ACADPref originalValue)
    (alert (strcat "The DisplayLayoutTabs preference was reset back to: " (if (= originalValue :vlax-true) "True" "False")))
)