GripColorSelected Property (ActiveX)

Specifies the color of selected grips.

Supported platforms: Windows only

Signature

VBA:

object.GripColorSelected
object

Type: PreferencesSelection

The object this property applies to.

Property Value

Read-only: No

Type: acColor enum

Control of the selected grips (drawn as filled boxes). The valid range is 1 to 255, or one of the constants listed here:

Remarks

The initial value of this property is 12.

Note: The value for this property is stored in the GRIPHOT system variable.

Examples

VBA:

Sub Example_GripColorSelected()
    ' This example reads and modifies the preference value that controls
    ' the color of selected grips.
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadPreferencesSelection
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the selection preferences object
    Set ACADPref = ThisDrawing.Application.preferences.Selection
    
    ' Read and display the original value
    originalValue = ACADPref.GripColorSelected
    MsgBox "The GripColorSelected preference is set to: " & originalValue

    ' Modify the GripColorSelected preference by setting it to green
    ACADPref.GripColorSelected = acGreen
    newValue = ACADPref.GripColorSelected
    MsgBox "The GripColorSelected preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.GripColorSelected = originalValue
    MsgBox "The GripColorSelected preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_GripColorSelected()
    ;; This example reads and modifies the preference value that controls
    ;; the color of selected grips.
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))    
    
    ;; Get the selection preferences object
    (setq ACADPref (vla-get-Selection (vla-get-preferences acadObj)))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-GripColorSelected ACADPref))
    (alert (strcat "The GripColorSelected preference is set to: " (itoa originalValue)))

    ;; Modify the GripColorSelected preference by setting it to green
    (vla-put-GripColorSelected ACADPref acGreen)
    (setq newValue (vla-get-GripColorSelected ACADPref))
    (alert (strcat "The GripColorSelected preference has been set to: " (itoa newValue)))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-GripColorSelected ACADPref originalValue)
    (alert (strcat "The GripColorSelected preference was reset back to: " (itoa originalValue)))
)