XRecord Object (ActiveX)

XRecord objects are used to store and manage arbitrary data.

Supported Platforms: Windows only

Class Information

Class Name

AcadXRecord

Object Inheritance
Object
   AcadObject
      AcadXRecord
Create Using

VBA

Dictionary.AddXRecord
Access Via

VBA

Dictionary.Item

Members

These members are part of this object:

Remarks

This object is similar in concept to XData but is not limited by size or order.

Unlike XData, XRecords work with the standard AutoCAD group codes that are all below 1000 in value. All the standard AutoCAD group codes are supported. This means that, in addition to all the normally used data types, an XRecord is capable of storing object IDs, which allows XRecords to own other objects including other XRecords.

The following group codes are common to all XRecord objects:

XRecord objects are saved with the drawing and are directly accessible by other ObjectARX and AutoLISP programs. So, if data security is an issue for your application, you should be careful when storing information in XRecords.

Note: XRecord objects are designed to work in such a way as to not offend Releases 13c0 through 13c3. However, if read into a pre-Release 13c4 level of AutoCAD, XRecord objects disappear.

To create an XRecord, use the AddXRecord method.