StoreSQLIndex Property (ActiveX)

Determines if the SQL index is stored in the drawing.

Supported platforms: Windows only

Signature

VBA:

object.StoreSQLIndex
object

Type: PreferencesSystem

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value for this property is True.

Examples

VBA:

Sub Example_StoreSQLIndex()
    ' This example reads and modifies the preference value that controls
    ' whether the SQL index is stored in the drawing.
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadPreferencesSystem
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the system preferences object
    Set ACADPref = ThisDrawing.Application.preferences.System
    
    ' Read and display the original value
    originalValue = ACADPref.StoreSQLIndex
    MsgBox "The StoreSQLIndex preference is set to: " & originalValue

    ' Modify the StoreSQLIndex preference by toggling the value
    ACADPref.StoreSQLIndex = Not (ACADPref.StoreSQLIndex)
    newValue = ACADPref.StoreSQLIndex
    MsgBox "The StoreSQLIndex preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.StoreSQLIndex = originalValue
    MsgBox "The StoreSQLIndex preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_StoreSQLIndex()
    ;; This example reads and modifies the preference value that controls
    ;; whether the SQL index is stored in the drawing.
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-StoreSQLIndex (vla-get-System preferences)))
    (alert (strcat "The StoreSQLIndex preference is set to: " (if (= originalValue :vlax-true) "True" "False")))

    ;; Modify the StoreSQLIndex preference by toggling the value
    (vla-put-StoreSQLIndex (vla-get-System preferences) (if (= originalValue :vlax-true) :vlax-false :vlax-true))
    (alert (strcat "The StoreSQLIndex preference has been set to: " (if (= (vla-get-StoreSQLIndex (vla-get-System preferences)) :vlax-true) "True" "False")))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-StoreSQLIndex (vla-get-System preferences) originalValue)
    (alert (strcat "The StoreSQLIndex preference was reset back to: " (if (= (vla-get-StoreSQLIndex (vla-get-System preferences)) :vlax-true) "True" "False")))
)