SegmentPerPolyline Property (ActiveX)

Specifies the number of line segments to be generated for each polyline curve.

Supported platforms: Windows only

Signature

VBA:

object.SegmentPerPolyline
object

Type: DatabasePreferences

The object this property applies to.

Property Value

Read-only: No

Type: Long

The number of line segments to be generated for each polyline curve.

0 < SegmentPerPolyline <= 42950

Remarks

The initial value is 8. The higher the number you specify, the greater the performance impact.

Note: The value of this property is stored in the SPLINESEGS system variable.

Examples

VBA:

Sub Example_SegmentPerPolyline()
    ' This example returns the current setting of
    ' SegmentPerPolyline. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim currSegmentPerPolyline As Integer
    Dim newSegmentPerPolyline As Integer
    
    ' Retrieve the current SegmentPerPolyline value
    currSegmentPerPolyline = ThisDrawing.preferences.SegmentPerPolyline
    MsgBox "The current value for SegmentPerPolyline is " & currSegmentPerPolyline, vbInformation, "SegmentPerPolyline Example"
    
    ' Change the value for SegmentPerPolyline
    newSegmentPerPolyline = 2001
    ThisDrawing.preferences.SegmentPerPolyline = newSegmentPerPolyline
    MsgBox "The new value for SegmentPerPolyline is " & newSegmentPerPolyline, vbInformation, "SegmentPerPolyline Example"
    
    ' Reset SegmentPerPolyline to its original value
    ThisDrawing.preferences.SegmentPerPolyline = currSegmentPerPolyline
    MsgBox "The SegmentPerPolyline value is reset to " & currSegmentPerPolyline, vbInformation, "SegmentPerPolyline Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_SegmentPerPolyline()
    ;; This example returns the current setting of
    ;; SegmentPerPolyline. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    (setq preferences (vla-get-Preferences doc))
    
    ;; Retrieve the current SegmentPerPolyline value
    (setq currSegmentPerPolyline (vla-get-SegmentPerPolyline preferences))
    (alert (strcat "The current value for SegmentPerPolyline is " (itoa currSegmentPerPolyline)))
    
    ;; Change the value for SegmentPerPolyline
    (setq newSegmentPerPolyline 2001)
    (vla-put-SegmentPerPolyline preferences newSegmentPerPolyline)
    (alert (strcat "The new value for SegmentPerPolyline is " (itoa newSegmentPerPolyline)))
    
    ;; Reset SegmentPerPolyline to its original value
    (vla-put-SegmentPerPolyline preferences currSegmentPerPolyline)
    (alert (strcat "The SegmentPerPolyline value is reset to " (itoa currSegmentPerPolyline)))
)