Prompt Method (ActiveX)

Displays a prompt on the command line.

Supported platforms: Windows only

Signature

VBA:

object.Prompt Message
object

Type: Utility

The object this method applies to.

Message

Access: Input-only

Type: String

The prompt to display.

Return Value (RetVal)

No return value.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_Prompt()
    ' This example will use the Utility object to display a prompt to the
    ' AutoCAD command line.  To see the results after running the example,
    ' switch to AutoCAD and look at the command line.
    
    ThisDrawing.Utility.Prompt "Press any key..."
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Prompt()
    ;; This example will use the Utility object to display a prompt to the
    ;; AutoCAD command line.  To see the results after running the example,
    ;; switch to AutoCAD and look at the command line.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    (vla-Prompt (vla-get-Utility doc) "Press any key...")
)