EndPlot Event (ActiveX)

Triggered after a document has been sent to the printer.

Supported platforms: Windows only

Signature

VBA:

object.EndPlot(DrawingName)
object

Type: Application, Document

An object expression that evaluates to a valid container object. In this case, the only valid containers are the application or a document.

DrawingName

Type: String; input to the handler

The name of the drawing that has been printed.

Remarks

No events will be fired while a modal dialog is being displayed.

Examples

VBA:

Private Sub AcadDocument_EndPlot(ByVal DrawingName As String)
    ' This example intercepts a drawing EndPlot event.
    '
    ' This event is triggered when a drawing finishes a plot request.
    '
    ' To trigger this example event: Plot an open drawing and wait for the plot to finish

    ' Use the "DrawingName" variable to determine which drawing just finished plotting
    MsgBox "A drawing has just finished a plot request!"
End Sub

Visual LISP:

Not available