TempFilePath Property (ActiveX)

Specifies the directory AutoCAD uses to store temporary files.

Supported platforms: Windows only

Signature

VBA:

object.TempFilePath
object

Type: PreferencesFiles

The object this property applies to.

Property Value

Read-only: No

Type: String

The drive and path of the directory used for temporary files.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_TempFilePath()
    ' This example returns the current setting of
    ' TempFilePath. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim preferences As AcadPreferences
    Dim currTempFilePath As String
    Dim newTempFilePath As String
    
    Set preferences = ThisDrawing.Application.preferences
    
    ' Retrieve the current TempFilePath value
    currTempFilePath = preferences.Files.TempFilePath
    MsgBox "The current value for TempFilePath is " & currTempFilePath, vbInformation, "TempFilePath Example"
    
    ' Change the value for TempFilePath
    newTempFilePath = "C:\AutoCAD\"
    preferences.Files.TempFilePath = newTempFilePath
    MsgBox "The new value for TempFilePath is " & newTempFilePath, vbInformation, "TempFilePath Example"
    
    ' Reset TempFilePath to its original value
    preferences.Files.TempFilePath = currTempFilePath
    MsgBox "The TempFilePath value is reset to " & currTempFilePath, vbInformation, "TempFilePath Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_TempFilePath()
    ;; This example returns the current setting of
    ;; TempFilePath. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Retrieve the current TempFilePath value
    (setq currTempFilePath (vla-get-TempFilePath (vla-get-Files preferences)))
    (alert (strcat "The current value for TempFilePath is " currTempFilePath))
    
    ;; Change the value for TempFilePath
    (setq newTempFilePath "C:\\AutoCAD\\")
    (vla-put-TempFilePath (vla-get-Files preferences) newTempFilePath)
    (alert (strcat "The new value for TempFilePath is " newTempFilePath))
    
    ;; Reset TempFilePath to its original value
    (vla-put-TempFilePath (vla-get-Files preferences) currTempFilePath)
    (alert (strcat "The TempFilePath value is reset to " currTempFilePath))
)