BeginOpen Event (ActiveX)

Triggered immediately after AutoCAD receives a request to open an existing drawing.

Supported platforms: Windows only

Signature

VBA:

object.BeginOpen(Filename)
object

Type: Application

An object expression that evaluates to a valid container object. In this case, the only valid container is the application.

Filename

Type: String

The name of the file being opened.

Remarks

The BeginOpen event is triggered as soon as AutoCAD receives a request to open an existing file. This request can come either interactively by a user through the File Open dialog box or programmatically.

The BeginOpen event does not trigger when opening a DXF format file.

When opening an existing file, the BeginOpen event will be followed by the EndOpen event when AutoCAD completes the opening of the drawing. For example, when a user selects Application menu Open, then chooses the file to open from the dialog box and selects the Open button, the BeginOpen event is triggered (as soon as the Open button is processed). Once the drawing is visible in the AutoCAD window and is ready for work, the EndOpen event is triggered.

When creating a new file, the NewDrawing event is triggered.

No events will be fired while a modal dialog is being displayed.

Examples

VBA:

Public WithEvents ACADApp As AcadApplication    ' Use with Application Event Examples
Sub Example_AcadApplication_Events()
    ' This example intializes the public variable (ACADApp) which will be used
    ' to intercept AcadApplication Events
    '
    ' The VBA WithEvents statement makes it possible to intercept an generic object
    ' with the events associated with that object.
    '
    ' Before you will be able to trigger any of the AcadApplication events,
    ' you will first need to run this procedure.
    
    ' We could get the application from the ThisDocument object, but that would
    ' require having a drawing open, so we grab it from the system.
    Set ACADApp = GetObject(, "AutoCAD.Application.20")
End Sub

Private Sub ACADApp_BeginOpen(FileName As String)
    ' This example intercepts an Application BeginOpen event.
    '
    ' This event is triggered when a drawing is opened by AutoCAD.
    '
    ' To trigger this example event:
    '     1) Make sure to run the example that initializes
    '     the public variable (named ACADApp) linked to this event.
    '
    '     2) Use AutoCAD to open an existing drawing

    ' Use the "FileName" variable to determine which drawing file is being opened
    MsgBox "A drawing is about to be loaded from: " & FileName
End Sub

Visual LISP:

Not available