A group of one or more AutoCAD objects specified for processing as a single unit.
Supported Platforms: Windows only
Class Information
- Class Name
-
AcadSelectionSet
- Object Inheritance
-
Object
AcadSelectionSet
- Create Using
-
VBA
SelectionSets.Add
- Access Via
-
VBA
SelectionSets.Item
Document.ActiveSelectionSet
Members
These members are part of this object:
Remarks
To delete a selection set, or delete items from a selection set, use one of the following methods:
- Clear: Empties the selection set. The selection set will still exist, but will not contain any items. The items that previously resided in the selection still exist, but they no longer reside in the selection set.
- RemoveItems: Removes one or more items from a selection set. The removed items still exist, but they no longer reside in the selection set.
- Erase: Deletes all items in a selection set. The selection set still exists, but will not contain any items. The items that previously resided in the selection set no longer exist.
- Delete: Deletes a selection set object, but not the objects in the selection set. While the selection set itself will not exist after the call to the Delete method, the items previously in the selection set will still exist.
To create a selection set, use the
Add
method.