Toggles the display of polar tracking vectors.
Supported platforms: Windows only
VBA:
object.PolarTrackingVector
Type: PreferencesDrafting
The object this property applies to.
Read-only: No
Type: Boolean
The initial value for this property is True.
VBA:
Sub Example_PolarTrackingVector() ' This example reads and modifies the preference value that controls ' the display of polar tracking vectors. ' When finished, this example resets the preference value back to ' its original value. Dim ACADPref As AcadPreferencesDrafting Dim originalValue As Variant, newValue As Variant ' Get the drafting preferences object Set ACADPref = ThisDrawing.Application.Preferences.Drafting ' Read and display the original value originalValue = ACADPref.PolarTrackingVector MsgBox "The PolarTrackingVector preference is set to: " & originalValue ' Modify the PolarTrackingVector preference by toggling the value ACADPref.PolarTrackingVector = Not (originalValue) newValue = ACADPref.PolarTrackingVector MsgBox "The PolarTrackingVector preference has been set to: " & newValue ' Reset the preference back to its original value ' ' * Note: Comment out this last section to leave the change to ' this preference in effect ACADPref.PolarTrackingVector = originalValue MsgBox "The PolarTrackingVector preference was reset back to: " & originalValue End Sub
Visual LISP:
(vl-load-com) (defun c:Example_PolarTrackingVector() ;; This example reads and modifies the preference value that controls ;; the display of polar tracking vectors. ;; When finished, this example resets the preference value back to ;; its original value. (setq acadObj (vlax-get-acad-object)) (setq preferences (vla-get-Preferences acadObj)) ' Get the drafting preferences object Set ACADPref = ThisDrawing.Application.preferences.Drafting ;; Read and display the original value (setq originalValue (vla-get-PolarTrackingVector (vla-get-Drafting preferences))) (alert (strcat "The PolarTrackingVector preference is set to: " (if (= originalValue :vlax-true) "True" "False"))) ;; Modify the PolarTrackingVector preference by toggling the value (vla-put-PolarTrackingVector (vla-get-Drafting preferences) (if (= originalValue :vlax-true) :vlax-false :vlax-true)) (setq newValue (vla-get-PolarTrackingVector (vla-get-Drafting preferences))) (alert (strcat "The PolarTrackingVector preference has been set to: " (if (= newValue :vlax-true) "True" "False"))) ;; Reset the preference back to its original value ;; ;; * Note: Comment out this last section to leave the change to ;; this preference in effect (vla-put-PolarTrackingVector (vla-get-Drafting preferences) originalValue) (alert (strcat "The PolarTrackingVector preference was reset back to: " (if (= originalValue :vlax-true) "True" "False"))) )