The collection of all user coordinate systems (UCSs) in the drawing.
Supported Platforms: Windows only
AcadUCSs
Object AcadObject AcadUCSs
VBA
Not applicable
VBA
Document.UserCoordinateSystems
These members are part of this object:
Methods |
Properties |
Events |
---|---|---|
To add a new member to the collection, use the Add method. To select a specific UCS, use the Item method. To delete a specific UCS, use the Delete method found on the UCS object.
Although the UCSs collection inherits a Delete method, you cannot actually delete the collection. Attempting to delete the UCSs collection will result in an error. The Delete method has been removed from the documentation for this collection.
There is no limit to the number of UCSs that you can create in your drawing. However, there can be only one instance of the UCSs collection. The UCSs collection is predefined for each drawing. You can make multiple references to the UCSs collection by using the UserCoordinateSystems property. Once done with an object, the reference is automatically released.