AltTabletMenuFile Property (ActiveX)

Specifies the path for an alternate menu to swap with the standard AutoCAD tablet menu.

Supported platforms: Windows only

Signature

VBA:

object.AltTabletMenuFile
object

Type: PreferencesFiles

The object this property applies to.

Property Value

Read-only: No

Type: String

The alternate tablet menu path.

Remarks

This property is applicable only if you use a digitizer.

Examples

VBA:

Sub Example_AltTabletMenuFile()
    ' This example returns the current setting of
    ' AltTabletMenuFile. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim preferences As AcadPreferences
    Dim currAltTabletMenuFile As String
    Dim newAltTabletMenuFile As String
    
    Set preferences = ThisDrawing.Application.preferences
    
    ' Retrieve the current AltTabletMenuFile value
    currAltTabletMenuFile = preferences.Files.AltTabletMenuFile
    If currAltTabletMenuFile = "" Then
        MsgBox "AltTabletMenuFile is not currently set.", vbInformation, "AltTabletMenuFile Example"
    Else
        MsgBox "The current value for AltTabletMenuFile is " & currAltTabletMenuFile, vbInformation, "AltTabletMenuFile Example"
    End If
    
    ' Change the value for AltTabletMenuFile
    newAltTabletMenuFile = "d:\acad\support\acad"
    preferences.Files.AltTabletMenuFile = newAltTabletMenuFile
    MsgBox "The new value for AltTabletMenuFile is " & newAltTabletMenuFile, vbInformation, "AltTabletMenuFile Example"
    
    ' Reset AltTabletMenuFile to its original value
    preferences.Files.AltTabletMenuFile = currAltTabletMenuFile
    If currAltTabletMenuFile = "" Then
        MsgBox "AltTabletMenuFile is reset to Null.", vbInformation, "AltTabletMenuFile Example"
    Else
        MsgBox "The AltTabletMenuFile value is reset to " & currAltTabletMenuFile, vbInformation, "AltTabletMenuFile Example"
    End If
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AltTabletMenuFile()
    ;; This example returns the current setting of
    ;; AltTabletMenuFile. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Retrieve the current AltTabletMenuFile value
    (setq currAltTabletMenuFile (vla-get-AltTabletMenuFile (vla-get-Files preferences)))
    (if (= currAltTabletMenuFile "")
        (alert "AltTabletMenuFile is not currently set.")
        (alert (strcat "The current value for AltTabletMenuFile is " currAltTabletMenuFile))
    )
    
    ;; Change the value for AltTabletMenuFile
    (vla-put-AltTabletMenuFile (vla-get-Files preferences) "C:\\AutoCAD\\acad")
    (alert (strcat "The new value for AltTabletMenuFile is " (vla-get-AltTabletMenuFile (vla-get-Files preferences))))
    
    ;; Reset AltTabletMenuFile to its original value
    (vla-put-AltTabletMenuFile (vla-get-Files preferences) currAltTabletMenuFile)
    (if (= currAltTabletMenuFile "")
        (alert "AltTabletMenuFile is reset to Null.")
        (alert (strcat "The AltTabletMenuFile value is reset to " (vla-get-AltTabletMenuFile (vla-get-Files preferences))))
    )
)