GetObject Method (ActiveX)

Gets the object in a dictionary, given the name (keyword) of the object.

Supported platforms: Windows only

Signature

VBA:

RetVal = object.GetObject(Name)
object

Type: Dictionary

The object this method applies to.

Name

Access: Input-only

Type: String

The name (keyword) of the object in the dictionary.

Return Value (RetVal)

Type: Object

The object corresponding to the given name (keyword).

Remarks

For example, querying the name "SecondKeyword" in the following dictionary would return the object "Object2":

MyDictionary

Keyword - Object

FirstKeyword - Object1

SecondKeyword - Object2

Examples

VBA:

Sub Example_GetObject()
    ' This example creates a dictionary and adds
    ' a custom object to that dictionary. It then
    ' returns the object using GetObject.
    
    Dim dictObj As AcadDictionary
    Set dictObj = ThisDrawing.Dictionaries.Add("TEST_DICTIONARY")
    
    ' Load the ARX application that defines the custom object.
    ' Note: The application listed here does not exist and
    ' will cause an error when run. Change the application name
    ' to the path and name of your ARX Application.
    On Error GoTo ERRORHANDLER
    ThisDrawing.Application.LoadArx "MyARXApp.dll"
    
    ' Create the custom object in the dictionary
    Dim keyName As String
    Dim className As String
    Dim customObj As AcadObject
    
    keyName = "OBJ1"
    className = "CAsdkDictObject"
    
    Set customObj = dictObj.AddObject(keyName, className)
    
    ' Find the object
    Dim tempObj As Object
    Set tempObj = dictObj.GetObject(keyName)
    
ERRORHANDLER:
    MsgBox Err.Description, , "GetObject Example"
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_GetObject()
    ;; This example creates a dictionary and adds
    ;; a custom object to that dictionary.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    (setq dictionaries (vla-get-Dictionaries doc))
  
    (setq dictObj (vla-Add dictionaries "TEST_DICTIONARY"))
    
    ;; Load the ObjectARX application that defines the custom object.
    ;; Note: The application listed here does not exist and
    ;; will cause an error when run. Change the application name
    ;; to the path and name of your ObjectARX application.
    (vla-LoadArx acadObj "MyARXApp.dll")
    
    ;; Create the custom object in the dictionary
    (setq keyName "OBJ1")
    (setq className "CAsdkDictObject")

    (setq customObj (vla-AddObject dictObj keyName className))

    ;; Find the object
    (setq tempObj (vla-GetObject dictObj keyName))
)