SolidFill Property (ActiveX)

Specifies if traces, solids, all hatches (including solid-fill), and wide polylines are filled in.

Supported platforms: Windows only

Signature

VBA:

object.SolidFill
object

Type: DatabasePreferences

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value of this property is True.

Note: The value of this property is stored in the FILLMODE system variable.

Examples

VBA:

Sub Example_SolidFill()
    ' This example reads and modifies the preference value that controls
    ' whether multilines, traces, solids, all hatches (including solid-fill)
    ' and wide polylines are filled in.
    '
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadDatabasePreferences
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the user preferences object
    Set ACADPref = ThisDrawing.Preferences
    
    ' Read and display the original value
    originalValue = ACADPref.SolidFill
    MsgBox "The SolidFill preference is set to: " & originalValue

    ' Modify the SolidFill preference by toggling the value
    ACADPref.SolidFill = Not (ACADPref.SolidFill)
    newValue = ACADPref.SolidFill
    MsgBox "The SolidFill preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.SolidFill = originalValue
    MsgBox "The SolidFill preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_SolidFill()
    ;; This example reads and modifies the preference value that controls
    ;; whether multilines, traces, solids, all hatches (including solid-fill)
    ;; and wide polylines are filled in.
    ;;
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))  
    (setq preferences (vla-get-Preferences doc))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-SolidFill preferences))
    (alert (strcat "The SolidFill preference is set to: " (if (= originalValue :vlax-true) "True" "False")))

    ;; Modify the SolidFill preference by toggling the value
    (vla-put-SolidFill preferences (if (= originalValue :vlax-true) :vlax-false :vlax-true))
    (setq newValue (vla-get-SolidFill preferences))
    (alert (strcat "The SolidFill preference has been set to: " (if (= newValue :vlax-true) "True" "False")))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-SolidFill preferences originalValue)
    (alert (strcat "The SolidFill preference was reset back to: " (if (= originalValue :vlax-true) "True" "False")))
)