About Setting AutoCAD Preferences (VBA/ActiveX)

There are nine objects pertaining to options, each representing a tab in the Options dialog box.

These objects provide access to all of the registry-stored options in the Options dialog box. You can customize many of the AutoCAD settings by using properties found on these objects. These objects are

These objects are accessible with the Preferences object. To gain access to the Preferences object, use the Preferences property of the Application object:

Dim acadPref as AcadPreferences
Set acadPref = ThisDrawing.Application.Preferences

You can then access any of the specific Preferences objects using the Display, Drafting, Files, OpenSave, Output, Profile, Selection, System, and User properties.

Set the crosshairs to full screen

Sub Ch2_PrefsSetCursor()
  ' This example sets the crosshairs of the AutoCAD drawing cursor
  ' to full screen.

  ' Access the Preferences object
  Dim acadPref As AcadPreferences
  Set acadPref = ThisDrawing.Application.Preferences

  ' Use the CursorSize property to set the size of the crosshairs
  acadPref.Display.CursorSize = 100
End Sub

Display the screen menu and scroll bars

Sub Ch2_PrefsSetDisplay()
  ' This example disables the scroll
  ' bars with the DisplayScrollBars
  ' properties.

  ' Access the Preferences object
  Dim acadPref As AcadPreferences
  Set acadPref = ThisDrawing.Application.Preferences

  ' Display the and disable scroll bars
  acadPref.Display.DisplayScrollBars = False
End Sub