Version Property (ActiveX)

Gets the version of the AutoCAD application you are using.

Supported platforms: Windows only

Signature

VBA:

object.Version
object

Type: Application

The object this property applies to.

Property Value

Read-only: Yes

Type: String

The version of AutoCAD that you are using.

Remarks

Note: The value of this property is stored in the ACADVER system variable.

Examples

VBA:

Sub Example_Version()
    ' This example returns AutoCAD version as a string
    
    Dim version As String
    version = ThisDrawing.Application.version
    MsgBox "This is AutoCAD Version " & version, , "Version Example"
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Version()
    ;; This example returns AutoCAD version as a string
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    (setq version (vla-get-Version acadObj))
    (alert (strcat "This is AutoCAD Version " version))
)