DemandLoadARXApp Property (ActiveX)

Specifies whether AutoCAD demand-loads a third-party application if a drawing contains custom objects.

Supported platforms: Windows only

Signature

VBA:

object.DemandLoadARXApp
object

Type: PreferencesOpenSave

The object this property applies to.

Property Value

Read-only: No

Type: acARXDemandLoad enum

Remarks

The initial value for this property is acDemandLoadOnObjectDetect + acDemandLoadCmdInvoke.

Note: The value for this property is stored in the DEMANDLOAD system variable.

Examples

VBA:

Sub Example_DemandLoadARXApp()
    ' This example returns the current setting of
    ' DemandLoadARXApp. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim preferences As AcadPreferences
    Dim currDemandLoadARXApp As Integer
    Dim constant As String
    Dim newConstant As String
    
    Set preferences = ThisDrawing.Application.preferences
    
    ' Retrieve the current DemandLoadARXApp value
    currDemandLoadARXApp = preferences.OpenSave.DemandLoadARXApp
    MsgBox "The current value for DemandLoadARXApp is " & currDemandLoadARXApp, vbInformation, "DemandLoadARXApp Example"
    
    ' Change the value for DemandLoadARXApp
    newConstant = acDemandLoadCmdInvoke
    preferences.OpenSave.DemandLoadARXApp = acDemandLoadCmdInvoke
    MsgBox "The new value for DemandLoadARXApp is " & newConstant, vbInformation, "DemandLoadARXApp Example"
    
    ' Reset DemandLoadARXApp to its original value
    preferences.OpenSave.DemandLoadARXApp = currDemandLoadARXApp
    MsgBox "The DemandLoadARXApp value is reset to " & currDemandLoadARXApp, vbInformation, "DemandLoadARXApp Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_DemandLoadARXApp()
    ;; This example returns the current setting of
    ;; DemandLoadARXApp. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Retrieve the current DemandLoadARXApp value
    (setq currDemandLoadARXApp (vla-get-DemandLoadARXApp (vla-get-OpenSave preferences)))
    (alert (strcat "The current value for DemandLoadARXApp is " (itoa currDemandLoadARXApp)))
    
    ;; Change the value for DemandLoadARXApp
    (setq newConstant acDemandLoadCmdInvoke)
    (vla-put-DemandLoadARXApp (vla-get-OpenSave preferences) newConstant)
    (alert (strcat "The new value for DemandLoadARXApp is " (itoa newConstant)))
    
    ;; Reset DemandLoadARXApp to its original value
    (vla-put-DemandLoadARXApp (vla-get-OpenSave preferences) currDemandLoadARXApp)
    (alert (strcat "The DemandLoadARXApp value is reset to " (itoa currDemandLoadARXApp)))
)