Files Property (ActiveX)

Gets the PreferencesFiles object.

Supported platforms: Windows only

Signature

VBA:

object.Files
object

Type: Preferences

The object this property applies to.

Property Value

Read-only: Yes

Type: PreferencesFiles

Gets the PreferencesFiles object.

Remarks

The PreferencesFiles object holds all the options from the Files tab on the Options dialog stored in the registry. All options that are stored with the drawing can be found on the DatabasePreferences object.

Examples

VBA:

Sub Example_Files()
    ' This example obtains a reference to the Files Preferences object
    ' from the Application Preferences object, and reads one of the File
    ' preferences
    
    Dim ACADPref As AcadPreferencesFiles
    
    ' Obtain a reference to the Files Preferences object
    Set ACADPref = ThisDrawing.Application.preferences.Files
    
    MsgBox "We now have access to the properties and methods of the Files Preferences object!"
    MsgBox "The File preference AutoSavePath is set to: " & ACADPref.AutoSavePath

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Files()
    ;; This example obtains a reference to the Files Preferences object
    ;; from the Application Preferences object, and reads one of the File
    ;; preferences
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))

    ;; Obtain a reference to the Files Preferences object
    (setq ACADPref (vla-get-Files preferences))
    
    (alert "We now have access to the properties and methods of the Files Preferences object!")
    (alert (strcat "The File preference AutoSavePath is set to: " (vla-get-AutoSavePath ACADPref)))
)