OLELaunch Property (ActiveX)

Determines whether to launch the parent application when plotting OLE objects.

Supported platforms: Windows only

Signature

VBA:

object.OLELaunch
object

Type: DatabasePreferences

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value of this property is False.

Plotting from the parent application achieves a higher quality plot; however, the speed of the plot is decreased.

Note: The value of this property is stored in the OLESTARTUP system variable.

Examples

VBA:

Sub Example_OLELaunch()
    ' This example reads and modifies the preference value that controls
    ' whether to launch the parent application when plotting OLE objects.
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadDatabasePreferences
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the user preferences object
    Set ACADPref = ThisDrawing.preferences
    
    ' Read and display the original value
    originalValue = ACADPref.OLELaunch
    MsgBox "The OLELaunch preference is set to: " & originalValue

    ' Modify the OLELaunch preference by toggling the value
    ACADPref.OLELaunch = Not (ACADPref.OLELaunch)
    newValue = ACADPref.OLELaunch
    MsgBox "The OLELaunch preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.OLELaunch = originalValue
    MsgBox "The OLELaunch preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_OLELaunch()
    ;; This example reads and modifies the preference value that controls
    ;; whether to launch the parent application when plotting OLE objects.
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))  
    (setq preferences (vla-get-Preferences doc))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-OLELaunch preferences))
    (alert (strcat "The OLELaunch preference is set to: " (if (= originalValue :vlax-true) "True"  "False")))

    ;; Modify the OLELaunch preference by toggling the value
    (vla-put-OLELaunch preferences (if (= originalValue :vlax-true) :vlax-false :vlax-true))
    (setq newValue (vla-get-OLELaunch preferences))
    (alert (strcat "The OLELaunch preference has been set to: " (if (= newValue :vlax-true) "True"  "False")))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-OLELaunch preferences originalValue)
    (alert (strcat "The OLELaunch preference was reset back to: " (if (= originalValue :vlax-true) "True"  "False")))
)