PickDrag Property (ActiveX)

Controls the method of drawing a selection window.

Supported platforms: Windows only

Signature

VBA:

object.PickDrag
object

Type: PreferencesSelection

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value of this property is False.

Note: The value for this property is stored in the PICKDRAG system variable.

Examples

VBA:

Sub Example_PickDrag()
    ' This example reads and modifies the preference value that controls
    ' the method of drawing a selection window.
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadPreferencesSelection
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the selection preferences object
    Set ACADPref = ThisDrawing.Application.Preferences.Selection
    
    ' Read and display the original value
    originalValue = ACADPref.PickDrag
    MsgBox "The PickDrag preference is set to: " & originalValue

    ' Modify the PickDrag preference by toggling the value
    ACADPref.PickDrag = Not (ACADPref.PickDrag)
    newValue = ACADPref.PickDrag
    MsgBox "The PickDrag preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.PickDrag = originalValue
    MsgBox "The PickDrag preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_PickDrag()
    ;; This example reads and modifies the preference value that controls
    ;; the method of drawing a selection window.
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))

    ;; Read and display the original value
    (setq originalValue (vla-get-PickDrag (vla-get-Selection preferences)))
    (alert (strcat "The PickDrag preference is set to: " (if (= originalValue :vlax-true) "True" "False")))

    ;; Modify the PickDrag preference by toggling the value
    (vla-put-PickDrag (vla-get-Selection preferences) (if (= originalValue :vlax-true) :vlax-false :vlax-true))
    (setq newValue (vla-get-PickDrag (vla-get-Selection preferences)))
    (alert (strcat "The PickDrag preference has been set to: " (if (= newValue :vlax-true) "True" "False")))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-PickDrag (vla-get-Selection preferences) originalValue)
    (alert (strcat "The PickDrag preference was reset back to: " (if (= originalValue :vlax-true) "True" "False")))
)