PrinterSpoolAlert Property (ActiveX)

Specifies whether to alert the user when the output to a device must be spooled through a system printer due to a conflict with the I/O port.

Supported platforms: Windows only

Signature

VBA:

object.PrinterSpoolAlert
object

Type: PreferencesOutput

The object this property applies to.

Property Value

Read-only: No

Type: acPrinterSpoolAlert enum

Remarks

The initial value for this property is acPrinterAlwaysAlert.

Examples

VBA:

Sub Example_PrinterSpoolAlert()
    ' This example reads and modifies the PrinterSpoolAlert
    ' preference value.
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadPreferencesOutput
    Dim originalValue As Integer
    
    ' Get the user preferences object

    Set ACADPref = ThisDrawing.Application.Preferences.Output
    
    ' Read and display the original value
    originalValue = ACADPref.PrinterSpoolAlert
    MsgBox "The PrinterSpoolAlert preference is set to: " & originalValue

    ' Modify the PrinterSpoolAlert preference by toggling the value
    ACADPref.PrinterSpoolAlert = acPrinterNeverAlert
    MsgBox "The PrinterSpoolAlert preference has been set to: " & ACADPref.PrinterSpoolAlert

    ' Reset the preference back to its original value
    ACADPref.PrinterSpoolAlert = originalValue
    MsgBox "The PrinterSpoolAlert preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_PrinterSpoolAlert()
    ;; This example reads and modifies the PrinterSpoolAlert
    ;; preference value.
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-PrinterSpoolAlert (vla-get-Output preferences)))
    (alert (strcat "The PrinterSpoolAlert preference is set to: " (itoa originalValue)))

    ;; Modify the PrinterSpoolAlert preference by toggling the value
    (vla-put-PrinterSpoolAlert (vla-get-Output preferences) acPrinterNeverAlert)
    (alert (strcat "The PrinterSpoolAlert preference has been set to: " (itoa (vla-get-PrinterSpoolAlert (vla-get-Output preferences)))))

    ;; Reset the preference back to its original value
    (vla-put-PrinterSpoolAlert (vla-get-Output preferences) originalValue)
    (alert (strcat "The PrinterSpoolAlert preference was reset back to: " (itoa (vla-get-PrinterSpoolAlert (vla-get-Output preferences)))))
)