About Migrating Automation Projects (VBA/ActiveX)

In general, an AutoCAD automation project created in the VBA IDE or created with Visual Studio might require some updates before it can be used in AutoCAD 2015.

AutoCAD 2015 automation projects use a new type library (acax20enu.tlb). The type library is located in C:\Program Files\Common Files\Autodesk Shared.

AutoCAD 2015 automation projects also use a new version-dependent ProgID for the CreateObject, GetObject, and GetInterfaceObject methods. For example, if you are using the CreateObject function in an AutoCAD automation project, you use CreateObject("AutoCAD.Application.20") to create an instance of AutoCAD 2015. Use CreateObject("AutoCAD.Application") to create an instance of the most recently executed AutoCAD or AutoCAD-based product if more than one product is installed.

New Objects

No new objects were added.

Changed Objects

The following table describes the changes made to existing objects.

AutoCAD 2014 AutoCAD 2015 Description of change

IAcadApplication

IAcadDatabase

IAcadDocument

IAcadIDPair

IAcadMLeader

IAcadObject

IAcadPViewport

IAcadTable

IAcadTableStyle

IAcadUtility

IAcadView

IAcadApplication

IAcadDatabase

IAcadDocument

IAcadIDPair

IAcadMLeader

IAcadObject

IAcadPViewport

IAcadTable

IAcadTableStyle

IAcadUtility

IAcadView

Methods and properties specific to Windows 64-bit are now obsolete and no longer available. Replace the obsolete method or property.

32-bit Projects on Windows 64-bit

Starting with AutoCAD 2014, AutoCAD uses VBA 7.1 which offers native 64-bit support. Earlier releases of AutoCAD 64-bit used and executed VBA 32-bit in an external process which caused performance issues. Projects developed for earlier releases require some considerations to work correctly with AutoCAD 2014. You need to take the following into consideration when migrating VBA projects from an earlier release: