Move Method (ActiveX)

Moves an object along a vector.

Supported platforms: Windows only

Signature

VBA:

object.Move Point1, Point2
object

Type: All drawing objects, AttributeReference, Dimension

The objects this method applies to.

Point1

Access: Input-only

Type: Variant (three-element array of doubles)

The 3D WCS coordinates specifying the first point of the move vector.

Point2

Access: Input-only

Type: Variant (three-element array of doubles)

The 3D WCS coordinates specifying the second point of the move vector.

Return Value (RetVal)

No return value.

Remarks

The two points you specify define a displacement vector indicating how far the given object is to be moved and in what direction.



Given object with two points indicated



Moved object

Examples

VBA:

Sub Example_Move()
    ' This example creates a circle and then performs
    ' a move on that circle.
    
    ' Create the circle
    Dim circleObj As AcadCircle
    Dim center(0 To 2) As Double
    Dim radius As Double
    center(0) = 2#: center(1) = 2#: center(2) = 0#
    radius = 0.5
    Set circleObj = ThisDrawing.ModelSpace.AddCircle(center, radius)
    ZoomAll
    
    ' Define the points that make up the move vector
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    point1(0) = 0: point1(1) = 0: point1(2) = 0
    point2(0) = 2: point2(1) = 0: point2(2) = 0
        
    MsgBox "Move the circle 2 units in the X direction.", , "Move Example"
    
    ' Move the circle
    circleObj.Move point1, point2
    
    ZoomAll
    MsgBox "Move completed.", , "Move Example"
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Move()
    ;; This example creates a circle and then performs
    ;; a move on that circle.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    ;; Create the circle
    (setq center (vlax-3d-point 2 2 0)
          radius 0.5)

    (setq modelSpace (vla-get-ModelSpace doc))
    (setq circleObj (vla-AddCircle modelSpace center radius))
    (vla-ZoomAll acadObj)
    
    ;; Define the points that make up the move vector
    (setq point1 (vlax-3d-point 0 0 0)
          point2 (vlax-3d-point 2 0 0))
        
    (alert "Move the circle 2 units in the X direction.")
    
    ;; Move the circle
    (vla-Move circleObj point1 point2)
    
    (vla-ZoomAll acadObj)
    (alert "Move completed.")
)