The following table provides summary descriptions of the AutoLISP object-handling functions.
Object-handling functions |
|
---|---|
Function |
Description |
(dumpallproperties ename [context]) |
Retrieves an entity’s supported properties |
(entdel ename) |
Deletes objects (entities) or restores previously deleted objects |
(entget ename [applist]) |
Retrieves an object's definition data |
(entlast) |
Returns the name of the last non-deleted main object in the drawing |
(entmake [elist]) |
Creates a new entity (graphical object) in the drawing |
(entmakex [elist]) |
Makes a new object, gives it a handle and entity name (but does not assign an owner), and then returns the new entity name |
(entmod elist) |
Modifies the definition data of an object |
(entnext [ename]) |
Returns the name of the next object in the drawing |
(entupd ename) |
Updates the screen image of an object |
(getpropertyvalue ename propertyname [or collectionName index name]) |
Returns the current value of an entity’s property |
(handent handle) |
Returns an object name based on its handle |
(ispropertyreadonly ename propertyname [or collectionName index name]) |
Returns the read-only state of an entity’s property |
(setpropertyvalue ename propertyname value [or collectionname index name val]) |
Sets the property value for an entity |
(vlax-dump-object obj) |
Lists an object's methods and properties Note: Extended AutoLISP extension: requires vl-load-com
|
(vlax-erased-p obj) |
Determines whether an object was erased Note: Extended AutoLISP extension: requires vl-load-com
|
(vlax-get-acad-object) |
Retrieves the top-level AutoCAD application object for the current AutoCAD session Note: Extended AutoLISP extension: requires vl-load-com
|
(vlax-method-applicable-p obj method) |
Determines whether an object supports a particular method Note: Extended AutoLISP extension: requires vl-load-com
|
(vlax-object-released-p obj) |
Determines whether an object has been released Note: Extended AutoLISP extension: requires vl-load-com
|
(vlax-read-enabled-p obj) |
Determines whether an object can be read Note: Extended AutoLISP extension: requires vl-load-com
|
(vlax-release-object obj) |
Releases a drawing object Note: Extended AutoLISP extension: requires vl-load-com
|
(vlax-typeinfo-available-p obj) |
Determines whether type library information is present for the specified type of object Note: Extended AutoLISP extension: requires vl-load-com
|
(vlax-write-enabled-p obj) |
Determines whether an AutoCAD drawing object can be modified Note: Extended AutoLISP extension: requires vl-load-com
|