vl-arx-import (AutoLISP)

Imports ObjectARX/ADSRX functions into a separate-namespace VLX

Supported Platforms: Windows and Mac OS

Signature

(vl-arx-import ['function | application])
function

Type: String

Symbol name for the function to import.

application

Type: String

Application name whose functions are to be imported.

Return Values

Type: nil

By default, separate-namespace VLX applications do not import any functions from ObjectARX/ADSRX applications. Use vl-arx-import to explicitly import functions from ObjectARX/ADSRX applications.

If executed from a document VLX, this function does nothing and returns nil, as all ADS-DEFUN function names are automatically imported to document VLX applications.

Remarks

If no argument (or nil) is specified, vl-arx-import imports all function names from the current document namespace.

Examples

To see how vl-arx-import works, try the following:

  1. Copy the following code into the Visual LISP editor and save the file:
    (vl-doc-export 'testarx)
    (defun testarx ()
       (princ "This function tests an ObjectARX application ")
       (vl-arx-import 'c:cal)
       (c:cal)
    )
  2. Use Make Application to build a VLX with this code. Select Separate-Namespace Application Options.
  3. Load geomcal.arx, if it is not already loaded.
  4. Load and run the application.

    To verify the effect of vl-arx-import, comment out the vl-arx-import call in the code, save the change, then rebuild and run the application. Without the vl-arx-import call, the c:cal function will not be found.

In the example above, you could have replaced the vl-arx-import call with the following:

(vl-arx-import "geomcal.crx")

This would import all functions defined in geomcal.crx, including c:cal.