atan (AutoLISP)

Returns the arctangent of a number in radians

Supported Platforms: Windows and Mac OS

Signature

(atan num1 [num2])
num1

Type: Integer or Real

A numeric value.

num2

Type: Integer or Real

A numeric value.

Return Values

Type: Real

The arctangent of num1, in radians, if only num1 is supplied. If you supply both num1 and num2 arguments, atan returns the arctangent of num1/num2, in radians. If num2 is zero, it returns an angle of plus or minus 1.570796 radians (+90 degrees or -90 degrees), depending on the sign ofnum1. The range of angles returned is -pi/2 to +pi/2 radians.

Examples

(atan 1)
0.785398

(atan 1.0)
0.785398

(atan 0.5)
0.463648

(atan -1.0)
-0.785398

(atan 2.0 3.0)
0.588003

(atan 2.0 -3.0)
2.55359

(atan 1.0 0.0)
1.5708