vlr-mouse-reactor (AutoLISP/ActiveX)

Constructs an editor reactor object that notifies of a mouse event (for example, a double-click)

Supported Platforms: Windows only

Signature

(vlr-mouse-reactor data callbacks)
data

Type: Integer, Real, String, List, VLA-object, safearray, variant, T, or nil

Any AutoLISP data to be associated with the reactor object; otherwise nil if no data.

callbacks

Type: List

A list of pairs of the following form:

(event-name . callback_function)

  • event-name is one of the following Mouse reactor events:

    Mouse reactor events

    Event name

    Description

    :vlr-beginDoubleClick

    The user has double-clicked.

    :vlr-beginRightClick

    The user has right-clicked.

  • callback_function is a symbol representing a function to be called when the event fires. Each callback function accepts two arguments:

    reactor_object -- The VLR object that called the callback function.

    list -- A list of extra data elements associated with the particular event. The contents of this list for particular events are shown in the “Mouse reactor callback data” table.

    Mouse reactor callback data

    Name

    List length

    Parameters

    :vlr-beginDoubleClick

    :vlr-beginRightClick

    1

    A 3D point list (list of 3 reals) showing the point clicked on, in WCS.

Return Values

Type: VLR object

The reactor_object argument from the callback_function.

Examples

N/A