Returns a substring of a string
Supported Platforms: Windows and Mac OS
(substr str start [length])
Type: String
A textual value.
Type: Integer
A positive numeric value indicating the starting position in str. The first character in the string is position 1.
Type: Integer
A positive numeric value specifying the number of characters to search through in str. If length is not specified, the substring continues to the end of str.
Type: String
A substring from str.
The substr function starts at the start character position of str and continues for length characters.
(substr "abcde" 2) "bcde" (substr "abcde" 2 1) "b" (substr "abcde" 3 2) "cd"