vlr-miscellaneous-reactor (AutoLISP/ActiveX)

Constructs an editor reactor object that does not fall under any other editor reactor types

Supported Platforms: Windows only

Signature

(vlr-miscellaneous-reactor data callbacks)
data

Type: Integer, Real, String, List, VLA-object, safearray, variant, T, or nil

Any AutoLISP data to be associated with the reactor object; otherwise nil if no data.

callbacks

Type: List

A list of pairs of the following form:

(event-name . callback_function)

  • event-name is one of the following Miscellaneous reactor events:

    Miscellaneous reactor events

    Event name

    Description

    :vlr-pickfirstModified

    The pickfirst selection set of the current document has been modified.

    :vlr-layoutSwitched

    The layout was switched.

  • callback_function is a symbol representing a function to be called when the event fires. Each callback function accepts two arguments:

    reactor_object -- The VLR object that called the callback function.

    list -- A list of extra data elements associated with the particular event. The contents of this list for particular events are shown in the “Miscellaneous reactor callback data” table.

    Miscellaneous reactor callback data

    Name

    List length

    Parameters

    :vlr-pickfirstModified

    0

    :vlr-layoutSwitched

    1

    A string naming the layout switched to.

Return Values

Type: VLR object

The reactor_object argument from the callback_function.

Examples

N/A