Curve Measurement Functions Reference (AutoLISP/ActiveX)

Note: ActiveX support in AutoLISP is limited to Windows only.

The following table provides summary descriptions of the AutoLISP curve measurement functions.

Curve measurement functions

Function

Description

(vlax-curve-getArea curve-obj)

Returns the area inside the curve

(vlax-curve-getClosestPointTo curve-obj givenPnt [extend])

Returns the point (in WCS coordinates) on a curve that is nearest to the specified point

(vlax-curve-getClosestPointToProjection curve-obj givenPnt normal [extend])

Returns the closest point (in WCS) on a curve after projecting the curve onto a plane

(vlax-curve-getDistAtParam curve-obj param)

Returns the length of the curve's segment from the curve's beginning to the specified parameter

(vlax-curve-getDistAtPoint curve-obj point)

Returns the length of the curve's segment between the curve's start point and the specified point

(vlax-curve-getEndParam curve-obj)

Returns the parameter of the endpoint of the curve

(vlax-curve-getEndPoint curve-obj)

Returns the endpoint (in WCS coordinates) of the curve

(vlax-curve-getFirstDeriv curve-obj param)

Returns the first derivative (in WCS coordinates) of a curve at the specified location

(vlax-curve-getParamAtDist curve-obj point)

Returns the parameter of a curve at the specified distance from the beginning of the curve

(vlax-curve-getParamAtPoint curve-obj dist)

Returns the parameter of the curve at the point

(vlax-curve-getPointAtDist curve-obj dist)

Returns the point (in WCS coordinates) along a curve at the distance specified by the user

(vlax-curve-getPointAtParam curve-obj param)

Determines the point on the curve that corresponds to the param parameter and returns the point

(vlax-curve-getSecondDeriv curve-obj param)

Returns the second derivative (in WCS coordinates) of a curve at the specified location

(vlax-curve-getStartParam curve-obj)

Returns the start parameter on the curve

(vlax-curve-getStartPoint curve-obj)

Returns the start point (in WCS coordinates) of the curve

(vlax-curve-isClosed curve-obj)

Determines if the specified curve is closed (i.e., start point is same as endpoint)

(vlax-curve-isPeriodic curve-obj)

Determines if the specified curve has an infinite range in both directions and there is a period value dT, such that there is a point on curve at ( u + dT) = point on curve ( u), for any parameter u

(vlax-curve-isPlanar curve-obj)

Determines if there is a plane that contains the curve