You can get information about a reactor that you created or those that have been created with other applications.
Note: ActiveX support in AutoLISP is limited to Windows only.
You can use the following functions to inspect a reactor object:
-
vlr-data-set
- Returns the type of the specified reactor. For example:
(vlr-type circleReactor)
:VLR-Object-Reactor
-
vlr-current-reaction-name
- Returns the name of the event that caused the callback function to be called. For example:
(vlr-current-reaction-name)
:VLR-modified
-
vlr-data
- Returns the application-specific data value attached to the reactor. For example:
(vlr-data circleReactor)
"Circle Reactor"
You can use this data to distinguish among multiple reactors that can fire the same callback function.
-
vlr-owners
- Returns a list of the objects in an AutoCAD drawing that fire notifications to an object reactor. For example, the following function call lists the objects that fire notifications to circleReactor:
(vlr-owners circleReactor)
(#<VLA-OBJECT IAcadCircle 03ad077c>)
-
vlr-reactions
- Returns the callback list of condition-function pairs of the specified reactor. The following example returns information about circleReactor:
(vlr-reactions circleReactor)
((:vlr-modified . PRINT-RADIUS))
Note: You can also use the Visual LISP Inspect feature to view information about reactor objects.