The following table provides summary descriptions of the AutoLISP ActiveX object-handling functions.
ActiveX Object-handling functions |
|
---|---|
Function |
Description |
(vlax-dump-object obj) |
Lists an object's methods and properties |
(vlax-erased-p obj) |
Determines whether an object was erased |
(vlax-get-acad-object) |
Retrieves the top-level AutoCAD application object for the current AutoCAD session |
(vlax-method-applicable-p obj method) |
Determines if an object supports a particular method |
(vlax-object-released-p obj) |
Determines if an object has been released |
(vlax-read-enabled-p obj) |
Determines whether an object can be read |
(vlax-release-object obj) |
Releases a graphical object |
(vlax-typeinfo-available-p obj) |
Determines whether type library information is present for the specified type of object |
(vlax-write-enabled-p obj) |
Determines whether an AutoCAD drawing object can be modified |