Symbol-Handling Functions Reference (AutoLISP)

The following table provides summary descriptions of the AutoLISP symbol-handling functions.

Symbol-handling functions

Function

Description

(atom item)

Verifies that an item is an atom

(atoms-family format [symlist])

Returns a list of the currently defined symbols

(boundp sym)

Verifies whether a value is bound to a symbol

(not item)

Verifies that an item evaluates to nil

(null item)

Verifies that an item is bound to nil

(numberp item)

Verifies that an item is a real or an integer

(quote expr)

Returns an expression without evaluating it

(set sym expr)

Sets the value of a quoted symbol name to an expression

(setq sym1 expr1 [sym2 expr2 ...])

Sets the value of a symbol or symbols to associated expressions

(type item)

Returns the type of a specified item

(vl-symbol-name symbol)

Returns a string containing the name of a symbol

(vl-symbol-value symbol)

Returns the current value bound to a symbol

(vl-symbolp object)

Identifies whether or not a specified object is a symbol