start_list (AutoLISP/DCL)

Starts the processing of a list in the list box or in the pop-up list dialog box tile

Supported Platforms: Windows only

Signature

(start_list key [operation [index]])
key

Type: String

Value that specifies a tile. This argument is case-sensitive.

operation

Type: Integer

A numeric value indicating the type of list operation to perform. You can specify one of the following:

1 -- Change selected list contents

2 -- Append new list entry

3 -- Delete old list and create new list (the default)

index

Type: Integer

A number indicating the list item to change by the subsequent add_list call. The first item in the list is index 0. If not specified, index defaults to 0.

The index argument is ignored if start_list is not performing a change operation.

Return Values

Type: String

The name of the list that was started.

Remarks

Subsequent calls to add_list affect the list started by start_list until the application calls end_list.

Note: Do not use the set_tile function between start_list and end_list function calls.

Examples

N/A