acad-pop-dbmod (AutoLISP)

Restores the value of the DBMOD system variable to the value that was most recently stored with acad-push-dbmod

Supported Platforms: Windows and Mac OS

Prerequisites: The AcApp ObjectARX application must be loaded before the function can be called, which is loaded by default.

Signature

(acad-pop-dbmod)
No arguments.

Return Values

Type: T or nil

Returns T if successful; otherwise, if the stack is empty, returns nil.

Remarks

This function pops the current value of the DBMOD system variable off an internal stack.

This function is used with acad-push-dbmod to control the DBMOD system variable. The DBMOD system variable tracks changes to a drawing and triggers save-drawing queries.