vlr-command-reactor (AutoLISP/ActiveX)

Constructs an editor reactor that notifies of a command event

Supported Platforms: Windows only

Signature

(vlr-command-reactor data callbacks)
data

Type: Integer, Real, String, List, VLA-object, safearray, variant, T, or nil

Any AutoLISP data to be associated with the reactor object; otherwise nil if no data is to be associated with the reactor.

callbacks

Type: List

A list of pairs of the following form:

(event-name . callback_function )

  • event-name is one of the following Command reactor events:

    Command reactor events

    Event name

    Description

    :vlr-unknownCommand

    A command not known to AutoCAD was issued.

    :vlr-commandWillStart

    An AutoCAD command has been called.

    :vlr-commandEnded

    An AutoCAD command has completed.

    :vlr-commandCancelled

    An AutoCAD command has been canceled.

    :vlr-commandFailed

    An AutoCAD command failed to complete.

  • callback_function is a symbol representing a function to be called when the event fires.

    Each callback function accepts two arguments:

    reactor_object -- The VLR object that called the callback function.

    list -- A list containing a single element, the string identifying the command.

Return Values

Type: VLR object

The reactor_object argument from the callback_function.

Examples

N/A