tblobjname (AutoLISP)

Returns the entity name of a specified symbol table entry

Supported Platforms: Windows and Mac OS

Signature

(tblobjname table-name symbol)
table-name

Type: String

Symbol table to be searched. The argument is not case-sensitive.

symbol

Type: String

Symbol to be searched for.

Return Values

Type: ads_name or nil

The entity name of the symbol table entry, if found.

The entity name returned by tblobjname can be used in entget and entmod operations.

Examples

The following command searches for the entity name of the block entry “ESC-01”:

(tblobjname "block" "ESC-01")
<Entity name: 1dca368>