grdraw (AutoLISP)

Draws a vector between two points, in the current viewport

Supported Platforms: Windows and Mac OS

Signature

(grdraw from to color [highlight])
from

Type: List

2D or 3D points (lists of two or three reals) specifying one endpoint of the vector in terms of the current UCS. AutoCAD clips the vector to fit the screen.

to

Type: List

2D or 3D points (lists of two or three reals) specifying the other endpoint of the vector in terms of the current UCS. AutoCAD clips the vector to fit the screen.

color

Type: Integer

Color used to draw the vector. A -1 signifies XOR ink, which complements anything it draws over and which erases itself when overdrawn.

highlight

Type: Integer

Other than zero, indicates that the vector is to be drawn using the default highlighting method of the display device (usually dashed).

If highlight is omitted or is zero, grdraw uses the normal display mode.

Return Values

Type: nil

Always returns nil.

Examples

N/A