Returns the value of a variant
Supported Platforms: Windows only
(vlax-variant-value var)
Type: variant
A variable containing a variant.
Type: Integer, Real, String, VLA-object, safearray, T, or nil
The value of the variable. If the variable does not contain a variant, an error occurs.
(vlax-variant-value varstr) "ghost" (vlax-variant-value varint) 5 (vlax-variant-value notvar) ; *** ERROR: bad argument type: variantp 6.0
The last example results in an error, because notvar does not contain a variant.