A keyword frame indicates a specific type of operation that occurs within the Visual LISP environment.
The keyword indicates the type of operation. Keyword frames will appear in only two locations, at the very top or very bottom of the stack.
The following types of keyword frames will appear only at the top of a stack:
Keyword frames (top) |
|
---|---|
Frame type |
Operation that occurred |
:ACMD-CALLBACK |
Registered AutoCAD command call. |
:AFTER-EXP |
Indicates that your program is interrupted in a debugging break mode, and the Step Into or Step Over command just stepped out of an expression. |
:ARQ-SUBR-CALLBACK |
Indicates a normal call from AutoCAD to a Visual LISP-defined function. |
:AXVLO-IO-CALLBACK :DWF :DWG |
Saves or restores a Visual LISP object in a DWG. |
:BEFORE-EXP |
Debugger break upon entering the function. This message will appear whenever you are stepping through using Step Into or Step Over, and the step is entering an expression (as opposed to just leaving an expression, which is indicated by the :AFTER-EXP keyword). |
:BREAK-POINT |
User-specified breakpoint. |
:ENTRY-NAMESPACE |
A call in the context of a separate-namespace VLX. |
:ERROR-BREAK |
General runtime error. The Show Message shortcut menu selection allows you to view more specific error messages. |
:FUNCTION-ENTRY |
Debugger break upon entering the function. The stack element following this message contains the call frame for the function in which the break occurred. |
:KBD-BREAK |
The PAUSE key was pressed, placing the program on hold. |
:PROTECT-ASSIGN |
Assignment of a value to a protected symbol. From the right-click shortcut menu, you can choose Show Message to view the variable name, the current value, and the new value that was attempted to be assigned to the variable. You can also choose the Inspect command to view the list containing the symbol, and the new value indicated following :PROTECT-ASSIGN. |
:REACTOR-CALLBACK |
Reactor call. |
:READ-ERROR |
Error during a read operation. The Show Message shortcut menu selection provides additional information about the error. |
:SYNTAX-ERROR |
Visual LISP encountered incorrect AutoLISP program syntax. |
The following types of keyword frames will appear only at the bottom of a stack:
Keyword frames (bottom) |
|
---|---|
Frame type |
Operation that occurred |
:ACAD-REQUEST |
A call to the function shown in the frame immediately above the :ACAD-REQUEST keyword frame was invoked from the AutoCAD Command prompt. |
:DCL-ACTION |
Execution of a DCL tile or dialog action was requested from AutoCAD. The keyword :DCL-ACTION is followed by two strings: the DCL dialog name and the value of the $KEY variable in the DCL action body. If a number appears, it is the value of the $REASON variable in the DCL action body. The frame immediately above the keyword describes the function call built from the action string. |
:INSPECT-EVAL |
Evaluation of an Inspect command. |
:INSPECT-VERBOSE |
Entrance into a drawing Inspect hook function. |
:TOP-COMMAND |
The Visual LISP IDE requested the action resulting in the first element placed within the stack. This situation occurs, for example, when a function is invoked directly from loading a selection or a file. |
:USER-INPUT |
The character string shown in the frame was entered from the Visual LISP Console window. The frame immediately above the keyword describes the expression as it was translated from the user input. If the input string is too long, right-click to open a shortcut menu, and choose Show Message to view the entire text. You can also choose the Inspect command to inspect the entered string. |
:WATCH-EVAL |
Evaluation of a watch expression. |