The following table identifies the commands in the Revit Platform UI Manage tab, and corresponding APIs.
Table 7: Settings in API and UI
UI command |
Associated API |
Reference |
Settings Project Information |
Document.ProjectInformation |
See the following note |
Settings Project Parameters |
Document.ParameterBindings (Only for Shared Parameter) |
|
Project Location panel |
Document.ProjectLocations Document.ActiveProjectLocation |
|
Settings Additional Settings Fill Patterns |
FilteredElementCollector filtering on class FillPatternElement |
See the following note |
Settings Materials |
FilteredElementCollector filtering on class Material |
|
Settings Object Styles |
Document.Settings.Categories |
See the following note |
Phasing Phases |
Document.Phases |
See the following note |
Settings Structural Settings |
Loads and related structural settings are available in the API |
See Revit Structure |
Settings Project Units |
Document.GetUnits() |
See Units |
Area and Volume Calculations (on the Room & Area panel) |
AreaVolumeSettings.GetAreaVolumeSettings() |
See the following note |
Table 8: ProjectInformation
Parameters |
Corresponding API |
Built-in Parameters |
Project Issue Date |
ProjectInfo.IssueDate |
PROJECT_ISSUE_DATE |
Project Status |
ProjectInfo.Status |
PROJECT_STATUS |
Client Name |
ProjectInfo.ClientName |
CLIENT_NAME |
Project Address |
ProjectInfo.Address |
PROJECT_ADDRESS |
Project Name |
ProjectInfo.Name |
PROJECT_NAME |
Project Number |
ProjectInfo.Number |
PROJECT_NUMBER |
Use the properties exposed by ProjectInfo to retrieve and set all strings. These properties are implemented by the corresponding built-in parameters. You can get or set the values through built-in parameters directly. For more information about how to gain access to these parameters through the built-in parameters, see Parameter in the Elements Essential section. The recommended way to get project information is to use the ProjectInfo properties.