Design Options

Design Options

Design options provide a way to explore alternative designs in a project. Design options provide the flexibility to adapt to changes in project scope or to develop alternative designs for review. You can begin work with the main project model and then develop variations along the way to present to a client. Most elements can be added into a design option. Elements that cannot be added into a design option are considered part of the main model and have no design alternatives.

The main use for Design options is as a property of the Element class. See the following example.

Code Region 15-7: Using design options

void Getinfo_DesignOption(Document document)
{
        // Get the selected Elements in the Active Document
        UIDocument uidoc = new UIDocument(document);
        ElementSet selection = uidoc.Selection.Elements;
        
        foreach (Autodesk.Revit.DB.Element element in selection)
        {
                // Use the DesignOption property of Element
                if (element.DesignOption != null)
                {
                        TaskDialog.Show("Revit", element.DesignOption.Name.ToString());
                }
        }
}

The following rules apply to Design Options