ColorIndex プロパティ(ActiveX)

カラー インデックスを指定します。

サポートされているプラットフォーム: Windows のみ

構文と要素

VBA:

object.ColorIndex
object

タイプ: AcCmColor

このプロパティが適用されるオブジェクト。

プロパティの値

読み込み専用: いいえ

タイプ: acColor 列挙型

既定の色指定は acByLayer です。0 から 256 のカラー インデックス番号か、以下の定数のうちの 1 つを使ってください。

注意

追加の注意はありません。

VBA:

Sub Example_ColorIndex()
    'This example draws a circle and
    'returns the closest color index.

    Dim col As AcadAcCmColor
    Set col = AcadApplication.GetInterfaceObject("AutoCAD.AcCmColor.20")
    col.SetRGB 125, 175, 235
    
    Dim cir As AcadCircle
    Dim pt(0 To 2) As Double
    Set cir = ThisDrawing.modelSpace.AddCircle(pt, 2)
    cir.TrueColor = col
    ZoomAll
    
    Dim retCol As AcadAcCmColor
    Set retCol = cir.TrueColor
    
    If col.ColorMethod = AutoCAD.acColorMethodByRGB Then
    MsgBox "Closest ColorIndex=" & col.ColorIndex
    End If

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ColorIndex()
    ;;This example draws a circle and
    ;;returns the closest color index.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))    

    (setq col (vlax-create-object "AutoCAD.AcCmColor.20"))
    (vla-SetRGB col 125 175 235)

    (setq pt (vlax-3d-point 0 0 0))

    (setq modelSpace (vla-get-ModelSpace doc))  
    (setq cir (vla-AddCircle modelSpace pt 2))
    (vla-put-TrueColor cir col)
    (vla-ZoomAll acadObj)
    
    (setq retCol (vla-get-TrueColor cir))
    
    (if (= (vla-get-ColorMethod col) acColorMethodByRGB)
        (alert (strcat "Closest ColorIndex=" (itoa (vla-get-ColorIndex col))))
    )

    (vlax-release-object col)
)