GetString メソッド(ActiveX)

ユーザから文字列を取得します。

サポートされているプラットフォーム: Windows のみ

構文と要素

VBA:

RetVal = object.GetString(HasSpaces [, Prompt])
object

タイプ: Utility

このメソッドが適用されるオブジェクト。

HasSpaces

アクセス: 入力のみ

タイプ: 長整数型

  • 0: 返される文字列にスペースを含めることはできません。改行またはスペースで終了します。
  • 1: 返される文字列にスペースを含めることができます。改行でのみ終了します。
Prompt

アクセス: 入力のみ; オプション

タイプ: バリアント型(文字列)

ユーザに入力を求めるときに表示される文字列。

戻り値(RetVal)

タイプ: 文字列

ユーザから返される文字列。

注意

AutoCAD は、ユーザが文字列を入力するのを待って、ユーザが入力した文字列に対する結果を設定します。HasSpaces パラメータは、文字列にスペースを含められるかどうかを指定します。Prompt パラメータは、ユーザ入力を求める際に AutoCAD が表示する文字列を指定します。

AutoCAD のユーザは、キーボードから文字列を入力できます。HasSpaces パラメータが True の場合、文字列に空白を含むことができ、ユーザは[Enter]を押して入力を終了する必要があります。HasSpaces が False の場合、空白を入力するか[Enter]を押して入力を終了します。133 文字以上の文字が入力された場合、空白が入力されるか[Enter]が押されるまで(HasSpaces で設定)文字列の入力は継続されますが、GetString メソッドは最初の 132 文字しか戻り値に設定しません。

VBA:

Sub Example_GetString()
    ' This example demonstrates different ways of returning a string
    ' entered by a user.
    
    AppActivate ThisDrawing.Application.Caption
    
    Dim returnString As String
    
    ' Prompt & Input cannot contain blanks
    returnString = ThisDrawing.Utility.GetString(False, "Enter text (a space or  terminates input): ")
    MsgBox "The string entered was '" & returnString & "'", , "GetString Example"
    
    ' Prompt & Input can contain blanks
    returnString = ThisDrawing.Utility.GetString(True, "Enter text ( terminates input):")
    MsgBox "The string entered was '" & returnString & "'", , "GetString Example"
    
    ' Prompt & Input can contain blanks, but not an empty string
    Dim NoNull As Integer
    NoNull = 1    ' Disallow null
    ThisDrawing.Utility.InitializeUserInput NoNull
    returnString = ThisDrawing.Utility.GetString(True, "Enter text ( terminates input): ")
    MsgBox "The string entered was '" & returnString & "'", , "GetString Example"

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_GetString()
    ;; This example demonstrates different ways of returning a string
    ;; entered by a user.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))    
    
    ;; Prompt & Input cannot contain blanks
    (setq returnString (vla-GetString (vla-get-Utility doc) :vlax-false "Enter text (a space or <enter> terminates input): "))
    (alert (strcat "The string entered was '" returnString "'"))
    
    ;; Prompt & Input can contain blanks
    (setq returnString (vla-GetString (vla-get-Utility doc) :vlax-true "Enter text (<enter> terminates input):"))
    (alert (strcat "The string entered was '" returnString "'"))
    
    ;; Prompt & Input can contain blanks, but not an empty string
    (setq NoNull 1)    ;; Disallow null
    (vla-InitializeUserInput (vla-get-Utility doc) NoNull)
    (setq returnString (vla-GetString (vla-get-Utility doc) :vlax-true "Enter text (<enter> terminates input): "))
    (alert (strcat "The string entered was '" returnString "'"))
)