TotalAngle プロパティ(ActiveX)

円弧の全角度を取得します。

サポートされているプラットフォーム: Windows のみ

構文と要素

VBA:

object.TotalAngle
object

タイプ: Arc

このプロパティが適用されるオブジェクト。

プロパティの値

読み込み専用: はい

タイプ: 倍精度浮動小数点数型

ラジアンで示した円弧の全長。

注意

追加の注意はありません。

VBA:

Sub Example_TotalAngle()
    ' This example creates an Arc in model space and
    ' returns the total angle of the new Arc
    
    Dim arcObj As AcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngleInDegree As Double, endAngleInDegree As Double
    Dim startAngleInRadian As Double, endAngleInRadian As Double
    
    ' Define the Arc
    centerPoint(0) = 0: centerPoint(1) = 0: centerPoint(2) = 0
    radius = 5#
    startAngleInDegree = 10#: endAngleInDegree = 230#

    ' Convert the angles in degrees to angles in radians
    startAngleInRadian = startAngleInDegree * 3.141592 / 180#
    endAngleInRadian = endAngleInDegree * 3.141592 / 180#
    
    ' Create the arc object in model space
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngleInRadian, endAngleInRadian)
    ThisDrawing.Application.ZoomAll
    
    ' Return length of new arc
    MsgBox "The total angle of the new Arc is: " & arcObj.TotalAngle
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_TotalAngle()
    ;; This example creates an Arc in model space and
    ;; returns the total angle of the new Arc
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    ;; Define the arc
    (setq centerPoint (vlax-3d-point 0 0 0)  
          radius 5
          startAngleInDegree 10
          endAngleInDegree 230)
    
    ;; Convert the angles in degrees to angles in radians
    (setq startAngleInRadian (/ (* startAngleInDegree 3.141592) 180))
    (setq endAngleInRadian (/ (* endAngleInDegree 3.141592) 180))
    
    ;; Create the arc object in model space
    (setq modelSpace (vla-get-ModelSpace doc))  
    (setq arcObj (vla-AddArc modelSpace centerPoint radius startAngleInRadian endAngleInRadian))
    (vla-ZoomAll acadObj)
    
    ;; Return length of new arc
    (alert (strcat "The total angle of the new Arc is: " (rtos (vla-get-TotalAngle arcObj) 2)))
)