次の表に、VBA の関数と、VB.NET および C# の関数および演算子の比較を示します。ActiveX ライブラリは「AutoCAD.Application」で示され、同等の .NET マネージ ライブラリは「Autodesk.AutoCAD」で示されます。VB.NET または C# の同等機能は関数または演算子として示されます。
演算関数 |
|
---|---|
ActiveX、VBA、または Visual Basic 6 |
VB.NET および C# の同等機能(指定のない場合は同じ) |
+ (加算演算子) |
+ (加算演算子) |
- (減算演算子) |
- (減算演算子) |
* (乗算演算子) |
* (乗算演算子) |
/ (除算演算子) |
/ (除算演算子) |
^ (指数演算子) |
^ (指数演算子) |
Abs 関数 |
System.Math.Abs 関数 |
Atn 関数 |
System.Math.Atan 関数 |
Cos 関数 |
System.Math.Cos 関数 |
Exp 関数 |
System.Math.Exp 関数 |
Log 関数 |
System.Math.Log 関数 |
Max 関数 |
System.Math.Max 関数 |
Min 関数 |
System.Math.Min 関数 |
Mod 関数 |
|
Sin 関数 |
System.Math.Sin 関数 |
Sqr 関数 |
System.Math.Sqrt 関数 |
条件文およびループ文 |
|
---|---|
ActiveX、VBA、または Visual Basic 6 |
VB.NET および C# の同等機能(指定のない場合は同じ) |
Do Until... Loop 文 |
|
Do While... Loop 文 |
|
For Each...Next 文 |
|
If... Then... Else...End If 文 |
|
Select Case 文 |
|
While... Wend 文 |
|
論理文 |
|
---|---|
ActiveX、VBA、または Visual Basic 6 |
VB.NET および C# の同等機能(指定のない場合は同じ) |
= (等しい比較演算子) |
|
<> (等しくない比較演算子) |
|
< (より少ない比較演算子) |
< (より少ない比較演算子) |
<= (より少ない、または等しい比較演算子) |
<= (より少ない、または等しい比較演算子) |
> (より大きい比較演算子) |
> (より大きい比較演算子) |
>= (より大きい、または等しい比較演算子) |
>= (より大きい、または等しい比較演算子) |
And 関数 |
|
Eqv 演算子 |
提供されません。代わりに他のビット方式の比較メソッドを使用してください |
Imp 演算子 |
提供されません。代わりに = 比較を使用してください |
Is 演算子 |
|
IsArray 関数 |
|
IsNull 関数 |
|
Like 演算子 |
|
Not 演算子 |
|
Or 関数 |
|
データ変換関数 |
|
---|---|
ActiveX、VBA、または Visual Basic 6 |
VB.NET および C# の同等機能(指定のない場合は同じ) |
Asc 関数 |
|
AutoCAD.Application.ActiveDocument. Utility.AngleToReal メソッド |
Autodesk.AutoCAD.Runtime.Converter. StringToAngle メソッド |
AutoCAD.Application.ActiveDocument. Utility.AngleToString メソッド |
Autodesk.AutoCAD.Runtime.Converter. AngleToString メソッド |
AutoCAD.Application.ActiveDocument. Utility.RealToString メソッド |
Autodesk.AutoCAD.Runtime.Converter. DistanceToString 関数 |
CDbl 関数 |
|
Chr 関数 |
|
CInt 関数 |
|
Fix 関数 |
|
Int 関数 |
|
Str 関数 |
|
StrConv 関数 |
|
基本的な文字列操作関数 |
|
---|---|
ActiveX、VBA、または Visual Basic 6 |
VB.NET および C# の同等機能(指定のない場合は同じ) |
& 演算子(連結文字列) |
|
Len 関数 |
|
Mid 関数 |
|
AutoCAD のコマンド プロンプト関数から入力を取得します |
|
---|---|
ActiveX、VBA、または Visual Basic 6 |
VB.NET および C# の同等機能(指定のない場合は同じ) |
AutoCAD.Application.ActiveDocument. Utility.GetAngle メソッド |
Autodesk.AutoCAD.ApplicationServices.Application. DocumentManager.MdiActiveDocument.Editor. GetAngle 関数 |
AutoCAD.Application.ActiveDocument. Utility.GetCorner メソッド |
Autodesk.AutoCAD.ApplicationServices.Application. DocumentManager.MdiActiveDocument.Editor. GetCorner 関数 |
AutoCAD.Application.ActiveDocument. Utility.GetDistance メソッド |
Autodesk.AutoCAD.ApplicationServices.Application. DocumentManager.MdiActiveDocument.Editor. GetDistance 関数 |
AutoCAD.Application.ActiveDocument. Utility.GetEntity メソッド |
Autodesk.AutoCAD.ApplicationServices.Application. DocumentManager.MdiActiveDocument.Editor. GetEntity 関数 |
AutoCAD.Application.ActiveDocument. Utility.GetInteger メソッド |
Autodesk.AutoCAD.ApplicationServices.Application. DocumentManager.MdiActiveDocument.Editor. GetInteger 関数 |
AutoCAD.Application.ActiveDocument. Utility.GetKeyword メソッド |
Autodesk.AutoCAD.ApplicationServices.Application. DocumentManager.MdiActiveDocument.Editor. GetKeyword 関数 |
AutoCAD.Application.ActiveDocument. Utility.GetOrientation メソッド |
Autodesk.AutoCAD.ApplicationServices.Application. DocumentManager.MdiActiveDocument.Editor. GetAngle 関数 |
AutoCAD.Application.ActiveDocument. Utility.GetPoint メソッド |
Autodesk.AutoCAD.ApplicationServices.Application. DocumentManager.MdiActiveDocument.Editor. GetPoint 関数 |
AutoCAD.Application.ActiveDocument. Utility.GetReal メソッド |
Autodesk.AutoCAD.ApplicationServices.Application. DocumentManager.MdiActiveDocument.Editor. GetDouble 関数 |
AutoCAD.Application.ActiveDocument. Utility.GetString メソッド |
Autodesk.AutoCAD.ApplicationServices.Application. DocumentManager.MdiActiveDocument.Editor. GetString 関数 |
AutoCAD.Application.ActiveDocument. Utility.InitializeUserInput |
Autodesk.AutoCAD.EditorInput. PromptKeywordOptions |
基本的な AutoCAD アプリケーションおよび図面関数 |
|
---|---|
ActiveX、VBA、または Visual Basic 6 |
VB.NET および C# の同等機能(指定のない場合は同じ) |
AutoCAD.Application.ActiveDocument. Utility.AngleFromXAxis メソッド |
Autodesk.AutoCAD.Geometry.Point2d(point1) GetVectorTo(point2).Angle プロパティ |
AutoCAD.Application.ListARX メソッド |
Autodesk.AutoCAD.Runtime.SystemObjects. DynamicLinker.GetLoadedModules 関数 |
AutoCAD.Application.LoadARX メソッド |
Autodesk.AutoCAD.Runtime.SystemObjects. DynamicLinker.LoadModule メソッド |
AutoCAD.Application.UnloadARX メソッド |
Autodesk.AutoCAD.Runtime.SystemObjects. DynamicLinker.UnloadModule メソッド |
AutoCAD.Application. Documents.Close メソッド |
Autodesk.AutoCAD.ApplicationServices.Application. DocumentManager.MdiActiveDocument. CloseAndDiscard メソッド または Autodesk.AutoCAD.ApplicationServices.Application. DocumentManager.MdiActiveDocument. CloseAndSave メソッド |
AutoCAD.Application.ActiveDocument. SendCommand メソッド |
Autodesk.AutoCAD.ApplicationServices.Application. DocumentManager.MdiActiveDocument. SendStringToExecute メソッド |
AutoCAD.Application.ActiveDocument. Dictionaries.Add メソッド |
|
AutoCAD.Application.ActiveDocument. Dictionaries.Item メソッド |
|
AutoCAD.Application.ActiveDocument. ModelSpace プロパティ |
|
AutoCAD.Application.ActiveDocument. ModelSpace.Item メソッド |
|
AutoCAD.Application.ActiveDocument. ModelSpace.Count プロパティ |
|
AutoCAD.Application.ActiveDocument. ModelSpace.Add<entityname> メソッド |
|
AutoCAD.Application.ActiveDocument. ActiveSpace プロパティ |
|
AutoCAD.Application.ActiveDocument. PaperSpace プロパティ |
|
AutoCAD.Application.ActiveDocument. ActiveLayout プロパティ |
|
AutoCAD.Application.ActiveDocument. PurgeAll メソッド |
HostApplicationServices.WorkingDatabase. Purge メソッド |
AutoCAD.Application.GetVariable メソッド |
Autodesk.AutoCAD.ApplicationServices.Application. GetSystemVariable 関数 |
AutoCAD.Application.MenuBar プロパティ |
Autodesk.AutoCAD.ApplicationServices.Application. MenuBar プロパティ |
AutoCAD.Application.MenuGroup プロパティ |
Autodesk.AutoCAD.ApplicationServices.Application. MenuGroups プロパティ |
AutoCAD.Application.ActiveDocument. PickfirstSelectionSet プロパティ |
Autodesk.AutoCAD.ApplicationServices.Application. DocumentManager.MdiActiveDocument.Editor. SelectImplied 関数 |
AutoCAD.Application.ActiveDocument. Utility.PolarPoint メソッド |
提供されません。新しい点を計算するには、Geometry 名前空間から Point2d および Point3d クラスを使用します |
AutoCAD.Application. Preferences プロパティ |
Autodesk.AutoCAD.ApplicationServices.Application. Preferences プロパティ |
AutoCAD.Application.ActiveDocument. Utility.Prompt メソッド |
Autodesk.AutoCAD.ApplicationServices.Application. DocumentManager.MdiActiveDocument.Editor. WriteMessage メソッド |
AutoCAD.Application.Quit メソッド |
Autodesk.AutoCAD.ApplicationServices.Application. Quit メソッド |
AutoCAD.Application.ActiveDocument. SelectionSets.Add メソッド |
必要ありません/提供されません |
AutoCAD.Application.ActiveDocument. SelectionSets.SelectionSet.Item メソッド |
Autodesk.AutoCAD.EditorInput.SelectionSet. selectionSet.Item(object)メソッド |
AutoCAD.Application.ActiveDocument. SelectionSets.SelectionSet.Delete メソッド |
Autodesk.AutoCAD.EditorInput.SelectionSet. selectionSet.Item(object).Delete メソッド |
AutoCAD.Application.ActiveDocument. SelectionSets.SelectionSet.SelectOnScreen メソッド |
Autodesk.AutoCAD.ApplicationServices.Application. DocumentManager.MdiActiveDocument.Editor. GetSelection メソッド |
AutoCAD.Application.ActiveDocument. SelectionSets.SelectionSet.Count プロパティ |
Autodesk.AutoCAD.EditorInput.SelectionSet. selectionSet.Count プロパティ |
AutoCAD.Application.ActiveDocument. SelectionSets.SelectionSet.SelectAtPoint メソッド |
Autodesk.AutoCAD.ApplicationServices.Application. DocumentManager.MdiActiveDocument.Editor. SelectCrossingWindow メソッド |
AutoCAD.Application.SetVariable メソッド |
Autodesk.AutoCAD.ApplicationServices.Application. SetSystemVariable メソッド |
AutoCAD.Application.ActiveDocument. Utility.TranslateCoordinates メソッド |
提供されません。異なる座標系の間で点を移動するには、Geometry 名前空間から Matrix3d クラスを使用します |
AutoCAD.Application.Version プロパティ |
Autodesk.AutoCAD.ApplicationServices.Application. Version プロパティ |
ThisDrawing |
Autodesk.AutoCAD.ApplicationServices.Application. DocumentManager.MdiActiveDocument プロパティ および HostApplicationServices.WorkingDatabase プロパティ |
基本的な VBA および Visual Basic 6 の関数および文 |
|
---|---|
ActiveX、VBA、または Visual Basic 6 |
VB.NET および C# の同等機能(指定のない場合は同じ) |
AppActivate AutoCAD.Application.Caption 関数 |
|
Dir 関数 |
System.IO.Directory.Exists 関数 |
Error オブジェクト/メソッド/プロパティ |
|
Function と End Function キーワード |
|
Input 関数 |
|
LBound(arrayName)関数 |
|
Line Input 関数 |
|
MsgBox 関数 |
MessageBox.Show メソッド |
object(n)文 |
|
Open 関数 |
System.IO.File.Open 関数 |
ReDim 文 |
|
Set 文 |
必要ありません/提供されません |
Shell 関数 |
|
Sub および End Sub キーワード |
|
TypeName 関数 |
|
UBound(arrayName)関数 |
|